What are the technical requirements for using Easy to Inspect?

Easy to Inspect can be used on any computer that has access to the internet. We advice to use a Google Chrome browser or Firefox.

If you carry out your inspections with a mobile device (smartphone or tablet), you can do so with iOS and Android devices. We support iOS operating systems version 11, 12 and 13 and Android operating systems version 8, 9 and 10. Older versions may work, but are no longer supported by Apelle or Google and there not by us. Please be aware of the fact, that if Android or Apple upgrades it’s operating system, this might have impact on the functioning of the App. We will update our App as soon as possible. For the Early Adopters, please check our support pages before updating your operating system. Please make sure that you have completed and uploaded all your inspection results to the database, before updating your devices operating system and before updating the Easy to inspect App to avoid loss of your data. Furthermore please be aware that other Apps installed on your device might impact performance.

Unfortunately, Easy to Inspect cannot be used as an App on on Blackberry and Windows Mobile devices. If you have such a device you are of course able to use Easy to Inspect through our webinterface!

Powered by BetterDocs